jenkins.io DNS issues
Incident Report for CloudBees
Resolved
All DNS servers are now consistent.

You may need to restart services to make them pick up the correct records.
Posted Jan 29, 2017 - 03:21 UTC
Update
Global DNS servers are still showing varying addresses for jenkins.io DNS records

https://dnschecker.org/#A/jenkins.io/140.211.15.101
Posted Jan 28, 2017 - 03:02 UTC
Monitoring
https://twitter.com/jenkinsci/status/825117522781310984

jenkins.io has propagated invalid DNS entries - these entries may be cached in your DNS server.

For any issues accessing jenkins.io update centres or resources we recommend checking your upstream DNS servers for correctness, flushing their caches, and restarting applications that have cached invalid entries.
Posted Jan 27, 2017 - 23:40 UTC